Demo Limitations

If you have recently downloaded the demo of Observatory 1.5, you may have stumbled in an overeager “Demo Limitations” dialog, displaying in quick succession. We have fixed the issue.

Please download the new Observatory Demo and replace yours with this one. If your demo has expired, don’t worry, this new build will automatically reset the expiration.