Welcome to Observatory

When you first open Observatory, you’ll see its welcome window pop open. It lets you quickly access this documentation, open an existing Observatory library, or create a new library. Creating a new library is what you want to do if this is the first time you use Observatory. Just click the New button.

Welcome window
Welcome window

A new window will pop open with your new untitled Observatory library document. This window is where you’ll do all of your work. You can create as many library documents as you wish. Observatory is not limited to a single library, and you can have multiple libraries open at the same time.

Before diving in, let’s take some time for a quick overview of Observatory’s user interface:

Empty new library window
Empty new library window
  1. Toolbar – Along the top of Observatory’s library window you’ll find a row of useful buttons in the Toolbar. Fully customizable the Toolbar makes it easy for you to switch between the different view modes, the Virtual Observatory, show the image download progress and a whole lot more. See Using the Toolbar for more details.

  2. Sidebar – Along the left side of Observatory’s window is the Sidebar. Fully collapsible, the Sidebar provides an outline view of all the albums, smart albums and folders in your library, an outline view of all source folders, and image previews. To learn more about the Sidebar, see Using the Sidebar.

  3. Unless created by dropping a Finder folder on Observatory’s application icon, initially an Observatory library does not contain any images. To help you quickly import a folder of images, click the Import Images… button in the center of the window. If you want to be more selective, click Add Source Folder… first. Lastly, if you wish to search for and import research images from the archives of professional observatories, just click the Virtual Observatory button instead. After you have imported one or more images, you can use the Toolbar to switch the window’s center contents between:

    • Browser – The Browser displays the images of the currently selected album, smart album or folder in your library. There are three kinds of Browsers. To learn more about them, see Using the Browser.

    • Editor – The Editor shows the image you have currently selected in the Browser in all its glory, or more specifically since you can have multiple images selected at once, the one that has the focus. The Editor can be shown at the same time as the Browser, or without it. Observatory also lets you display multiple editors at once. Using the Editor has more details about the Editor.

    • Virtual Observatory – The Virtual Observatory gives you direct access to 10+ professional archives and download research images from ESO, Keck, Gemini, Palomar, Hubble, Spitzer, WISE, 2MASS, SDSS and more. You can search for images by name and equatorial coordinates, optionally with help of the SIMBAD and NED astronomical databases. You can learn move about the Virtual Observatory in Using the Virtual Observatory.

  4. Inspector – Along the right side of Observatory’s window are the Inspectors. Fully collapsible and consisting of the Image Version, Layer Adjustment, Measure, Stack and Collection inspectors, as well as inspectors for attachments, channels, layers and the histogram, it provides access to most of the tools for adjusting selected images and their meta data. For more details about the Inspectors and what each of them does, see the Using the Inspectors section in the documentation.

Getting Started

To get to know Observatory, start with a library for a single target object and a limited number of images, e.g. 5 bias, 5 dark and 5 flat images, all optional, and 5 light images.

We regularly add videos to our website that demonstrate certain aspects of Observatory. This includes calibration, stacking, plate solving and how to find images with Virtual Observatory. Choose Help ▸ Videos to see them.

Create or Open a Library

Create a new empty library by clicking the New button in the welcome window, or choose File ▸ New Library in the main menu. Open an existing library by choosing it in the Open Recent menu of the welcome window or main menu, by clicking the Open… button in the welcome window or choosing File ▸ Open… (⌘O) in the main menu.

Alternatively, click and drag the Finder folder containing the target object’s images and drop it onto the Observatory application icon. This creates a new library and immediately imports the images.

Import Images

When you import an image into an Observatory library, it stores a reference to the image, and extracts its meta data (dimensions, exposure date/time, exposure duration, etc). Observatory never copies, moves or alters this master image.

If you want to import a folder of images into a library, choose File ▸ Import ▸ Images… (⇧⌘I), select the folder and click Import.

You can only select and import individual images into a library if you have given Observatory permission to access their containing folder. Choose File ▸ Import ▸ Add Source Folder…, select the folder and click Add Source Folder. Then choose File ▸ Import ▸ Images… (⇧⌘I), select the individual files and click Import.

Notice how FITS, XISF and SBIG images are displayed with actual thumbnails and previews in the Import Dialog and in the Finder. Observatory includes Quick Look generators to accomplish this feat, as well as Spotlight importers for helping you find images with Spotlight. Select any image in the Import Dialog or Finder and press spacebar to quickly see it up-close.

Put your bias, dark, flat and light images in appropriate albums. You may put them all in a single album, or organize them in multiple albums. Select the images, and choose Image ▸ Move to New Album. Make sure to put related images that you intend to stack in the same album. You can have multiple stacks in an album.

View Images

After importing images into a new Observatory library, their thumbnails are displayed in the Image Browser. The thumbnail size can be adjusted by the slider in the Browser Bar towards the bottom of the Browser.

Browser Bar
Browser Bar

To view an image in more detail, double click it. Alternatively, select it and choose View ▸ Show Browser & Editor (⌥⌘⏎), or click the corresponding button in the Toolbar.

Show Browser & Editor
Show Browser & Editor

Instead of only displaying the Browser, Observatory will then display the Browser together with the full image in the Editor.

Choose View ▸ Editor ▸ Assistant, or click the button in the Toolbar, and select another image while pressing the option key. This image will then appear next to the other image. Choose View ▸ Editor ▸ Focus Next Editor (⌥⌘`) to switch between them, or click their title bar in the Editor.

Assistant Editor Toolbar Button
Assistant Editor Toolbar Button

Choose View ▸ Editor ▸ Standard, or click the corresponding button in the Toolbar to switch back to a single editor.

Create Master Calibration Images

Select the bias images and choose Stack ▸ Stack. This creates a single, stacked image from the selection. Select the stack and use the Stack Inspector towards the right of Observatory’s library window to change how the images are stacked, e.g. Average (the default) or Median. Do the same for your dark and flat images.

Stack Inspector
Stack Inspector

The stack image of a stack is not like a regular image on disk, but generated dynamically. To do any further processing of it or use it as calibration image, a snapshot must be created. Select the bias, dark and flat stacks, and choose Image ▸ New ▸ Master.

Select the new master image of the bias stack that you have just created, and choose Image ▸ Move to Album ▸ Bias Calibration. This moves it into the library’s master calibration album and adjusts its image type accordingly. Being in this album makes the master bias calibration image available to the Calibrate Adjustment you will use later.

Do the same for the dark and flat images, moving the master dark by choosing Image ▸ Move to Album ▸ Dark Calibration and the master flat by choosing Image ▸ Move to Album ▸ Flat Calibration.

Calibrate

Select the light images and choose Layer ▸ Calibrate. The Layer Adjustment tab towards the right of the window will now display the Calibrate Adjustment inspector.

Calibrate Inspector
Calibrate Inspector

Select the master bias, dark and flat in this inspector. The inspector only lists the calibration images relevant to your selection. It displays only those that have the same dimensions, and also takes exposure time, CCD temperature (if set) and filter name into account. If it doesn’t display the expected calibration images, check if this information matches with your light images.

Stack

Select the light images and choose Stack ▸ Stack. Select the stack and then choose Average (the default) or Median in the Stack Inspector.

With the stack still selected, choose Stack ▸ Focus on Stack (⌃⌘[), or click the button in the Focus Bar.

Focus Bar: Focus on Stack
Focus Bar: Focus on Stack

Observatory will now display the stack’s comprising images. The center of the Focus Bar has three buttons that allow you to quickly select the stack image (the result of stacking the images), the stack’s current pick image, or all images in the stack, respectively.

These three buttons can also be used in combination with the option key and the Assistant Editor. For example, you can use them to quickly display the stack image in the right-hand side editor, and individual images in the left-hand side editor during stacking.

Align

Aligning images in a stack is always relative to the stack’s pick image. Typically, the pick image is the best or most representative image in the stack. Initially the pick is the earliest exposed image in the stack, but you can change it by selecting another image and choosing Stack ▸ Pick (⌃⌘8).

Select all images in the stack by choosing Stack ▸ Select ▸ All Items or clicking the button in the Focus Bar.

Choose Layer ▸ Stack ▸ Align.

This adds an Align Adjustment to each image, in addition to the Calibrate Adjustment. After processing has completed, the images will be aligned with the pick image, and the stack image is updated.

Align Inspector
Align Inspector

With all images still selected, click the “play” button in the Editor to quickly inspect the alignment. It changes into a “pause” button during the blink animation. Click it when done.

Blink Selection
Blink Selection

Now choose Stack ▸ Unfocus (⌃⌘]) or click the Unfocus button in the Focus Bar.

Export

Select the calibrated & aligned stack image and choose File ▸ Export ▸ Image… (⇧⌘E) to export it in the desired format. Observatory has powerful folder and file naming template support, but for now just select None as Folder Format, Name as Name Format, and click the Export button.

Plate Solve

Select the calibrated & aligned stack image, and choose Image ▸ New ▸ Master. For a regular image you can skip this step.

Choose Image ▸ Match… (⌃⌘M), then enter the name of the object in the image, and click Match All.

After a few seconds, the image will be plate solved and a badge icon appears on the image thumbnail.

If Observatory is unable to plate solve the image, choose Image ▸ Match… again and click the triangle to expand the match settings. Make sure that the pixel scale is fairly accurate. For large detectors the image may be distorted near the corners, and the frame size setting should be reduced. For noisy images increase the detector sensitivity setting.

Choose Overlay ▸ Show All Overlays to display the equatorial grid, scale, Messier, NGC/IC and other overlays on the image.

In addition to relating image pixels to sky coordinates, Observatory’s plate solver also automatically tags the image with data from its object database. You can then more easily find the images in the Browser by using its search field, or rely on the predefined Smart Albums in the Objects folder of the sidebar.

Virtual Observatory

At any time you can choose View ▸ Show Virtual Observatory (⇧⌘F) to search the archives of professional observatories for research images. Enter the target’s object name, identifier or coordinates and click Search. You can filter the search results, or by expanding the Preview panel in the sidebar see image previews before downloading the FITS images. Move the mouse cursor over the preview and click the Quick Look button to see a larger preview image. Click Import to download the FITS image into the Observatory library.

Alternatively, select the plate solved image, press the option key and choose View ▸ Match Virtual Observatory (⌥⇧⌘F). This initiates a search in the archives using the center coordinates of the image.

Save the Observatory Library

For checking the quality of your images during or after an observation session there is no need to save the library afterwards, but usually you would save it. Choose File ▸ Save… (⌘S) and enter the name of your library (e.g. “Observatory Library”), and its location. Lastly click the Save button.