Working in Observatory

Although you can create a single library for all your images by just dragging the folder on top of the Observatory application icon, which allows you to view their metadata, organize them in albums without the fear of modifying the original data, and focus on them by object category, there’s much more you can do with Observatory.

Here are some ideas to get started.

Quickly organize your images with the Finder

Because macOS doesn’t know what a FITS, XISF or SBIG file is, after acquiring images they all are displayed as generic icons in the Finder. Wouldn’t it be nice if you could at least see actual thumbnails, full previews and image metadata directly in the Finder?

With Observatory you will, because it includes Quick Look and Spotlight plugins for FITS, XISF and SBIG files. They work quietly in the background, and you don’t even need to run Observatory itself for this to work.

In the Finder, but also in Open/Save Dialogs of any application, these images are now displayed as thumbnails. You can take a closer look by pressing spacebar and view select metadata in the Finder with Get Info (⌘I). You can also use Spotlight to find images. Not just by file name, but also by exposure date, image type, dimensions, exposure duration, focal length, detector temperature, filter name, equatorial coordinates and many more attributes found in your images.

Check the images of last night’s imaging session

When you wake up the next morning, drag the folder containing the images of last night’s imaging session and drop it onto the Observatory application icon.

After a few seconds, you will be presented with a window containing all the images and see their metadata. Here you can quickly visually inspect them, determine FWHMs and reject those you dislike by choosing Stack ▸ Reject (⌃⌘0).

When you’re done, select the rejected ones and choose Image ▸ Show Master in Finder. A Finder window opens with the rejected images selected. There you can opt to drop them in a separate folder (New Folder with Selection), or move them to the trash all together.

Afterwards, you can just close the Observatory window, without even saving the newly created library.

Create a library for prospective targets

While preparing an imaging session for a list of targets, why not create a library, and use Virtual Observatory to download each target’s images from the DSS, SDSS, PTF or other archives? It may lead you to other interesting objects nearby.

Each target having its own library

Create a library for each target object, collecting observations spanning multiple observation sessions. Add master calibration frames, calibrate, align, and stack the images. Plate solve the stacked image, overlay astronomical catalog data, and export the image for post processing. Save the library to maintain a processing history.

A library of calibration frames

Use a library to collect all your calibration frames, auto-stack them, quickly inspect individual images using the blink animation, and export them as master calibration frames in 32 bit floating point FITS format. Use Observatory’s powerful export feature with folder and file naming templates to ensure that your master calibration frames are exported with consistent naming.

Research projects

For example, create a “Kuiper belt” library, add folders for individual objects and in each folder add albums with observations obtained through various instruments. Add your own observations and research images obtained through Observatory’s Virtual Observatory feature. Attach research papers to albums and individual images, add notes, tags and color code them.

Did anything change?

There’s a goldmine of raw image data available through Virtual Observatory. Align and blink some with your image. If your image is plate solved, it only takes one keystroke to take you there (⌃⇧⌘F).

Organize your images with the Finder even more

Quick Look and Spotlight are great, but you are still manually grouping the images with the Finder, based on their timestamp, type or target. Observatory can help you to make that easier too, and it doesn’t care if you forgot to update your settings during acquisition and all your files are named 00000127.DARK.FITS, 00000128.DARK.FITS, ….

Drag the folder with the images and drop it onto the Observatory application icon. Select them all in the Observatory browser, and choose Image ▸ Move to New Album. While they are still all selected, choose Stack ▸ Auto-Stack.

Now your images are grouped by their timestamp, type, filter name, CCD temperature, etc. They didn’t get organized like this in the Finder though. To do that, select one stack, click Stack ▸ Unstack (⌃⌘U), and choose Image ▸ Show Master in Finder. In the Finder window that opens, choose New Folder with Selection. Repeat this for each stack.

Afterwards, you can just close the Observatory window, without saving.

Convert images

If you have an old folder full of SBIG images, you can easily convert them all to the FITS format.

Drag the folder with the images and drop it onto the Observatory application icon. Select them all in the Observatory browser and choose File ▸ Export ▸ Master Image…. Select the destination folder and click the Export button to start the export.

Observatory’s export capabilities actually go well beyond this. You can export to many more image formats, resize images during exporting, use file naming templates and more.