The Stack Inspector

When importing images, it is best to organize them in albums. Not only to keep things organized, but also because only images that are filed in albums (not “Unfiled”) can be stacked. Image stacking is a digital image processing technique which combines multiple images into one to obtain a single high quality image.

For example, you may want to combine a set of dark frames into a single master dark. Or you may want to calibrate, align and combine images into a single one.

If you have a set of images in an album that you wish to stack, select them, and then choose Stack ▸ Stack. This will create a single stacked image from all those source images. Usually the images you want to stack will be of the same type, dimensions, have the same exposure duration, are taken at nearly equal CCD temperatures, etc. Observatory therefore also has an alternative method of stacking: by selecting all images in an album, and then choosing Stack ▸ Auto-Stack, observatory will create multiple stacks, taking the image type, dimensions, etc into account.

When you stack images in the browser, they are replaced by a single image. You can recognize these from their stack badge:

Stack Browser Badge
Stack Browser Badge

What happened is that Observatory created a new image by averaging the corresponding pixels of your original images. If you switch to the Stack Inspector along the right side of Observatory’s window, you’ll see that the stack type is “Average”.

Stack Inspector
Stack Inspector

You can choose between the following stack types:

When you select a stack, and choose Image ▸ Focus on Stack (^⌘[), or click the Focus on Stack button in the Browser Focus Bar, the Browser will display the images that you used to create the stack. If you switch to the Browser List View, you’ll see a property that is unique to images that are part of a stack: Weight.

Focus Bar: Focus on Stack
Focus Bar: Focus on Stack

Initially the weight for all images comprising a stack is 100%. This means they take fully part in the creation of the stack image. Sometimes however you may want to give a higher priority to the sharpest images in the stack, and use less sharper images to reduce noise. All the above listed stack types take the weight into account when computing the stack image.

To adjust the weight, select all images comprising the stack (click the button), and choose one of the options under Stack ▸ Auto-Weight. Observatory will then compute a weight for each of the images. The choices are:

For RGB images, it is important to select the channel for which you want this to be measured. If you don’t, then the values will be an average of the red, green and blue channels. Select the channel in the Channels panel.

You can also reject an image altogether, by choosing Stack ▸ Reject (⌃⌘0), increase or decrease a weight by choosing Stack ▸ Promote (⌃⌘=) or Stack ▸ Demote (⌃⌘-), and reset it to 100 % by choosing Stack ▸ Accept (⌃⌘1).

While combining images, Observatory will also use each source image’s layer opacity as a weight.

You can add layer adjustments to the images comprising a stack. For example, you can calibrate each, double them in size, and then align them with each other. The stack image is automatically updated whenever you make changes to the stack. Most of these layer adjustments are also available to images that are not part of a stack, but some (e.g. align) are only available for images in a stack because they require a reference image. This reference image is call a Pick. When creating a stack, initially the Pick is the image with the earliest exposure time, but you can change it by choosing Stack ▸ Pick (⌃⌘8).

Because the stack image is managed by Observatory (it is automatically generated and updated), you cannot manipulate that image directly. To do that, you’ll need to select it and choose Image ▸ New ▸ Master. This will freeze the current state of your stack image into a new managed master. You would do this also when you create a master calibration frame through stacking, by creating and then moving that managed master to one of the calibration albums.

Note that although you can create a single stack for a set of images, because creating versions is light-weight (choose Image ▸ New ▸ Duplicate Version), for experimentation with the weights it may be useful to create multiple stacks for the same master images.

We regularly add videos to our website that demonstrate certain aspects of Observatory, including calibration and stacking. Choose Help ▸ Videos to see them.