Using the Sidebar

Along the left edge of Observatory’s window is the collapsable Sidebar. The Sidebar lists the image collections in the Library Navigator along with the Preview and Source Folder panes. Near the bottom of the Sidebar, you’ll also find a Search field that makes it easy for you to sift through your collections and find the information you’re looking for.

Sidebar
Sidebar

The Sidebar is open by default, but you can hide and show it again by choosing View ▸ Sidebar ▸ Hide/Show Sidebar (⌘0), or by clicking the Sidebar button in the toolbar.

If you mouse over the right edge of the Sidebar, you’ll notice that the mouse pointer changes to a resizing handle. Click and drag the resizing handle to resize the Sidebar.

The Library Navigator

The upper half of the Sidebar displays the image collections in your library in a scrollable pane. These collections consist of Folders, Albums and Smart Albums:

In this Library Navigator, items with children have a disclosure triangle on the left edge. To view the children, click the disclosure triangle to flip open the list. Option-click a disclosure triangle to open or close all of the items within.

The Library Navigator is organized in three parts:

You create a new album by choosing Collection ▸ New Album. Alternatively, you can select a few images, and choose Image ▸ Add to New Album. Albums you create can be moved around and into folders, which can be created by choosing Collection ▸ New Folder. You can also drop an Album onto another Album, in which case they will be merged. To create a Smart Album, choose Collection ▸ New Smart Album.

The Library Navigator’s contextual menu, displayed by holding the Control key while clicking, provides quick access to these and other handy menu commands.

You can accentuate a collection in the Library Navigator by assigning a color label to it with the Collection Inspector. There you can also add Tags, assign a Rating or Status to it. In addition, you can add notes and attachments to your own collections. When you do not want any further modifications to a collection, lock it by choosing Collection ▸ Lock, or use the lock button in the Collection Inspector.

Sometimes you may have created a library for which you are not interested in certain default collections. For example, if your library only contains fully calibrated images, you may never even use the Calibration folders. Wouldn’t it be nice to have the ability to hide them? Well you can, by selecting the collection in the Library Navigator, and choosing Collection ▸ Hide Folder. Similarly you can hide Albums and Smart Albums.

To temporarily show the hidden collections, choose Collection ▸ Show Hidden. The ones that are marked as hidden will be shown with a gray font. You can permanently show them once again by choosing Collection ▸ Unhide Folder, or the equivalent for Albums and Smart Albums.

Searching Within the Library Navigator

If you have many collections in your library, you might need some help finding the one you are looking for.

At the bottom of the Library Navigator, you’ll see a search field with a little magnifying glass icon in it. After you have clicked it, the Library Navigator will display only those collections that match the search criteria with every character you type . You can search by collection Name, Tag or Status. Or you can search for any of them, which is the default.

To clear the search field, press Escape or click the little Clear search button at its right edge. When you’ve finished searching, the Library Navigator reverts back to its former state of showing you everything.

The Image Preview Panel

Near the bottom of the Sidebar, below the Library Navigator, is the Preview panel. It has a disclosure button at its left which, when clicked, reveals and hides the panel. The click area actually covers the whole panel’s title bar, so you don’t have to be too accurate when clicking. Alternatively you can choose View ▸ Sidebar ▸ Show/Hide Preview.

If you are using the Virtual Observatory, and select a search result that is marked with a ● symbol, revealing the Preview panel will have it automatically download a preview image and display it. Likewise, if you select an image in the Browser, the Preview panel will contain a small preview of that image. This is especially useful if you are using the List Browser.

If you want to have a closer look at a preview image, just move the cursor over it and click the Quick Look button that appears. This is especially useful for Virtual Observatory previews, since they are not restricted in size.

You can use the Quick Look window to open the preview image in other applications, for example the Preview application. If you wish to keep it or modify it, please Duplicate it first, because the original preview image may be removed while you use Observatory.

The Source Folder Panel

At the bottom of the Sidebar, the Source Folder panel is located. It has a disclosure button at its left which, when clicked, reveals and hides the panel. The click area actually covers the whole panel’s title bar, so you can click anywhere in it to show or hide the panel. Alternatively you can choose View ▸ Sidebar ▸ Show/Hide Source Folders.

A source folder represents a folder in the file system, outside of the Observatory library. Because the macOS Sandbox restricts access to the file system, it is up to you to explicitly give Observatory permission to access the folders in which your images reside, by choosing File ▸ Import ▸ Images… (⇧⌘I) or File ▸ Import ▸ Add Source Folder…. The Source Folder Panel keeps tracks of these folders. Neither these folders, nor their contents, is ever modified by Observatory.

If you choose File ▸ Import ▸ Add Source Folder…, the selected source folders, and optionally all their subfolders will be added to the Source Folder Panel. No images will be imported. Only the source folders are made available to Observatory. If you then choose File ▸ Import ▸ Images…, you will be able to select individual images in these source folders to import into Observatory.

If you skip the File ▸ Import ▸ Add Source Folder… step and choose File ▸ Import ▸ Images… directly, your selected source folders will also be added, and optionally all their subfolders, but also all their images will be imported. So importing images can be done in a single step, but that has the restriction that you will not be able to select specific images for importing.

You can make Observatory unaware of a previously added Source Folder by choosing File ▸ Import ▸ Remove Source Folder…. Be aware that the images in your library that originate from that Source Folder will also be removed, without moving them to Trash first. Your master images in the file system will not be affected of course.

The Source Folder Panel action popup menu provides quick access to these and other handy menu commands.