Sharing, Printing & Exporting

Share

With Observatory you can quickly share one or more images with others. Just select them in the Browser and click the Share button in the Toolbar of the library.

Share
Share

Depending on your selections in the System Preferences ▸ Extensions ▸ Share Menu settings, you will be presented with the ability to email the images, add them as a note to the Notes application, create a message in Messages, a Facebook post, a tweet on Twitter, etc.

Sharing an image by email
Sharing an image by email

Included in the message is the image, and usually also the image version name, basic metadata and the notes. What exactly is included depends on the service you are targeting. You can edit the information before sending it. The image is converted to JPEG with the current view settings.

Print

By selecting images in the Browser and choosing File ▸ Print… (⌘P) you can print images, their version name, basic metadata and the notes. Each selected version is printed on a separate page. If the image is matched, the image may be printed with the overlays.

Print
Print

Export as PDF…

You can quickly create a PDF file from the images and some of their metadata you have selected in the Browser by choosing File ▸ Export as PDF…. It is a shortcut for printing to a PDF file. Each image, its version name, basic metadata and the notes is added to a separate page in the PDF. As is the case with printing, if the image is Matched, it optionally includes the overlays.

Export

Observatory has powerful image export capabilities that allow you to convert your images to different file formats, resizing them, apply file naming templates, all while storing them in folders that use naming templates.

You define these file format, file naming and folder naming template using the Export Preferences.

Export Format

The Export Format determines the output file format, as well its dimensions. These dimensions may be the same as those of the source image version, a percentage of its size, or resized to fit within a given rectangular size. You can define your own formats, or use one of the defaults:

Default Export Formats
Name Description
Original Size (FITS) Output as 32 bit floating point FITS file
Original Size (FITS 16) Output as signed 16 bit integer FITS file
Original Size (TIFF) Output as TIFF file
Original Size (JPEG) Output as JPEG file
Original Size (PNG) Output as PNG file
Large Size (JPEG) Output as JPEG file (fit within 1280 × 1280)
Large Size (PNG) Output as PNG file (fit within 1280 × 1280)
Medium Size (JPEG) Output as JPEG file (fit within 640 × 640)
Medium Size (PNG) Output as PNG file (fit within 640 × 640)
Small Size (JPEG) Output as JPEG file (fit within 320 × 320)
Small Size (PNG) Output as PNG file (fit within 320 × 320)

Folder Naming Templates

When you export images, you select an output folder where the images will be exported to. The images can be exported simply as files immediately in this output folder, or in a deeper subfolder structure which reflects certain aspects of each image or its album. The Folder Naming Template determines this subfolder structure.

Default Folder Naming Templates
Name Description
None Do not create subfolders
Observation Date Create YYYYMMDD subfolders, based on image exposure date
Album Create subfolders with lowercase name of image’s album
Name Create subfolders with lowercase image version’s name
Album / Observation Date Create nested subfolders based on album name and exposure date
Name / Observation Date Create nested subfolders based on version name and exposure date

File Naming Templates

When you export images, you can simply use the version name as output name, but also let various attributes of the image determine its file name. The File Naming Template defines this naming pattern.

Default File Naming Templates
Name Description
Master Bias Lowercase name for master bias
Master Dark Lowercase name for master dark
Master Flat Lowercase name for master flat
Processed Lowercase name for processed image
Name Lowercase version name

Exporting Images

To export images, select them in the Browser and choose File ▸ Export ▸ Image… (⇧⌘E). This will export the selected versions. If you wish to export their master versions instead, choose File ▸ Export ▸ Master Image…. In both cases you are presented with a Dialog where you select the export destination folder. In addition, the following options are shown:

After selecting the destination folder and the various options, click the Export button to start the export.

Exporting Managed Masters

If you have used Virtual Observatory to obtain images from professional observatories, these will be stored as Managed Masters in the library. They are indicated with a special badge in the browser:

Managed Master Browser Badge
Managed Master Browser Badge

To export these original, unmodified images, choose File ▸ Export ▸ Managed Master….

Note that the same badge is also used for Managed Masters that were created using Image ▸ New ▸ Master. These kinds of masters you can only export through one of the methods described in the section Exporting Images.