Using the Editor

The Editor displays the currently focused image of the browser. It can be shown simultaneously with the browser by choosing Show Browser & Editor (⌥⌘⏎), or on its own by choosing Show Editor Only (⌘⏎). The latter is especially useful if you select all images you are working on beforehand in the browser.

Editor
Editor

It works in cooperation with the selections in the Histogram, Layers and Channels panels to display the image:

Towards the top of the Editor, the name of the focused image is being displayed. If the image is a stack of images, the stack icon is shown left of the name. The center of the Editor contains the canvas. The current zoom (or magnification) level, as well as the option to change the zoom using the popup button can be found on the bottom right hand side of the Editor Bar. You can also choose View ▸ Zoom In (⌘+) and View ▸ Zoom Out (⌘-) to change the zoom. Choose View ▸ Actual Size (⌘1) to quickly zoom to 100%, and View ▸ Zoom to Fit (⌘9) to center and zoom the image to fit in the canvas.

If you have the Zoom in or out and Smart zoom gestures enabled in your trackpad system preferences, then you can also pinch with two fingers to zoom in and out, and quickly switch between the current zoom level and 200% by double-tapping the canvas with two fingers. You can also quickly zoom in and out by pressing the Option key while using a mouse’s scroll wheel.

The image can be moved around (panned) in the canvas using the scrollbars. Alternatively, you can click and drag the mouse pointer, or just use the panning gesture of your trackpad.

Editor Bar

Besides controlling the editor’s zoom level, the Editor Bar displays the current cursor pixel position as well as the pixel value at this position. For grayscale images only one value is displayed, but for RGB images up to three values may be displayed, one for each channel.

Editor Bar
Editor Bar

While you move the cursor over an image, you will occasionally see three concentric circles appear near the cursor position. You may need to switch to 100% or 200% to see it. It consists of an inner filled circle, the aperture, surrounded by a doughnut shape, the annulus. The sizes of these shapes are determined by the Centroid Settings.

Aperture and Annulus
Aperture and Annulus

The pixels in the annulus area around the cursor position are used to compute the local background value. This value is subtracted from the value for each pixel in the aperture area. The resulting values are then used to compute the centroid position. If successful, the FWHM of the gaussian profile is computed.

These values are displayed in the Editor Bar. For RGB images, the displayed values are an average over the selected channels, so its a good idea to select a single channel (e.g. Green).

If you select multiple image in the browser, only the focused image is displayed in the editor. You can use the Go Back and Go Forward buttons next to the zoom popup button to focus on another image in the selection, or press the ⌘[ and ⌘] keys. Here you can also blink between these images by pressing the Play/Pause Animation button.

Centroid Settings

At the far left of the Editor Bar is the Centroid Settings button. Clicking it reveals a popup window, which can be used to adjust the aperture radius, annulus gap and annulus width. The gap is a “dead zone” in which all pixels are ignored. It prevents stars near the target from being measured.

For best results, after you have located a few centroid positions in your image and measured their FWHM values, revise the aperture to the appropriate radius of 3–5 FWHM.

To close the popup window, click outside it or click the top-right button. With the button next to it you can reset the aperture radius, annulus gap and annulus width to their default values. With the first button you can hide the background, centroid and FWHM values from the editor.

The centroid settings are not only used for the editor, but also for the Photometry Inspector and when matching images.

Overlay Catalogs

Images that have been astrometrically matched (plate solved) contain all the information to relate image pixels to sky coordinates. These images are indicated in the browser with the Browser Badge for a Matched Image badge. If you move the cursor over an image that has been matched, the Cursor Inspector in the Measure tab along the right side of Observatory’s window will not only show its pixel position, but also the corresponding right ascension and declination.

In addition, the Editor canvas may overlay information of many astronomical objects onto your image. The Overlay menu allows you to toggle image scale, orientation and RA/dec grid, as well as the Messier and NGC/IC objects, galaxies from the PGC2003 catalog and stars of the Tycho–2 catalog. It optionally also overlays the positions of the solar system’s planets and Pluto onto your image. If you have the UCAC4 and/or USNO-A2.0 catalogs installed, these can be displayed as well.

Images that have not been matched can be matched by choosing Image ▸ Match… (⌃⌘M).

The Assistant Editor

Assistant Editor Toolbar Button
Assistant Editor Toolbar Button

By default, the editor only displays a single image canvas. This is called the The Standard Editor. Sometimes you may want to see multiple images at the same time, for example to

You can do this by choosing View ▸ Editor ▸ Assistant or by clicking the corresponding button in the toolbar. The canvas will split in two, with on the left hand side the standard editor, and on the right hand side the assistent editor. You can move the splitter horizontally.

Assistant Editor
Assistant Editor

Switch between them by clicking on their title bar. Alternatively choose View ▸ Editor ▸ Focus Next Editor (⌥⌘`) or View ▸ Editor ▸ Focus Previous Editor (⌥⇧⌘`). Use the + button to add an additional editor, or the - button to remove one. They are added above each other, separated by a splitter that can move vertically.

When you select images in the browser, the focused image is displayed in the active editor. Press the Option key while selecting an image in the browser to make it appear in the editor that is not currently selected.

To quickly switch back to a single Standard Editor, choose View ▸ Editor ▸ Standard or click the corresponding button in the toolbar.