The Layer Adjustments Inspector

Layer Adjustments are nondestructive image editing tools that adjust your image without permanently changing its pixels. You can edit and discard your adjustments or restore your original image at any time.

You can use them with regular image versions as well as with image versions that are part of a stack. As you will see later, some adjustment can only be used inside a stack.

To get started, select the image, and select the layer you wish to work with in the Layers Panel. Most of the time, your image only consist of a single layer, in which case you can skip this step.

Bring up the Layer Adjustments Inspector by either clicking the corresponding button along the right side of Observatory’s window, or by choosing View ▸ Inspectors ▸ Layer Adjustments.

When you first do this for an image, you’ll see that it has no adjustments. After all, when you have imported an image, its first image version is the same as the master image.

Layer Adjustments Inspector
Layer Adjustments Inspector

You add an adjustment by clicking the + button at the bottom right, and choosing one of the adjustments, or by choosing it in the Layer menu. This will add the adjustment to the Layer Adjustments Inspector. For example, if you choose Layer ▸ Rotate ▸ Rotate, it will add:

Layer Adjustment: Rotate
Layer Adjustment: Rotate

Here the rotation angle was changed to 20°. Most adjustments allow you to change some of their options.

You are not limited to adding layer adjustments to images individually. You can select multiple images and apply the same adjustments to each.

Adjustment basics

Adding adjustments

You add an adjustment by clicking the + button at the bottom right of the Layer Adjustments Inspector, and choosing one of the adjustments, or by choosing it in the Layer menu.

Removing adjustments

To remove any adjustment, click on the X button in the upper right hand corner of the adjustment.

Moving adjustments

Adjustment are applied in the order they are shown in the Adjustments Inspector. To move an adjustment up or down, just drag and drop it to the location you desire. Do this by putting your mouse cursor between the disclosure triangle and adjustment title, and dragging it up or down to another position.

Resetting adjustment values

You can reset all the values in an adjustment by clicking the circular arrow located between the visibility and delete buttons.

Adjustment: Reset
Adjustment: Reset

Visibility

Click on the eye button in the adjustment to toggle its visibility. The visibility determines whether it will participate as an adjustment. It is a handy way to see the effects of an adjustment on your image.

Adjustment: Visible
Adjustment: Visible

Adjusting parameters

Many adjustments have values you can adjust through popup buttons, sliders or number entry. Some adjustments contain options that can be manipulated directly on your image such as the rotation angle of the Rotate adjustment. To toggle the visibility of “on image” adjustment controls, click the HUD button (the circle with two dots). Click the HUD button again to hide it from the Editor canvas.

Adjustment: Show HUD
Adjustment: Show HUD

Resizing the image canvas

In Observatory, a layer consists of one (grayscale) or three (RGB) channels, which are all of the exact same size. An image consists of one or more of these layers. The image dimensions do not need to match those of its layers though, and the layers can be placed with different offsets in the image’s canvas. You can change the image dimensions by choosing Image ▸ Resize Canvas….

If you want the canvas to be large enough to encompass the largest layer in your image, choose Image ▸ Resize Canvas…, click Adjust canvas to fit layers and then the OK button. All layers will then be fully presented within the canvas boundaries.

Adjustments

Calibrate

Bias, dark and flat field correction using the calibration images from the Bias Calibration, Dark Calibration and Flat Calibration albums. The layer dimensions, CCD temperature (±0.5 ℃), exposure duration and filter name are taken into account for this. Archived calibration images are ignored.

The adjustment has the following options. Each is initialized from one of the calibration albums. You do not need to select a value for each option.

If you are not seeing the calibration images you had expected, make sure that the relevant metadata matches for your image and its calibration images.

Using an image for image calibration

Select the image, for example a master dark frame, and choose Image ▸ Move to Album ▸ Calibration ▸ Master Dark ▸ Dark Calibration. Observatory will ask you for confirmation of modifying its image type when doing that.

If you created a master calibration image by stacking multiple images in Observatory, then you first need to create a Managed Master of it, since a stack cannot be used directly as calibration image. Select the stack and then choose Image ▸ New ▸ Master. Then choose Image ▸ Move to Album ▸ Calibration ▸ Master Dark ▸ Dark Calibration to use it as a master dark.

Offset

Repositions the layer.

Double Size

Doubles the size of the layer in both directions. After calibrating a layer, this adjustment is recommended before aligning layers within a stack.

Half Size

Reduces the size of the layer in both directions.

Resize

Resizes the layer in both directions using a scaling factor.

Binning

Reduces the size of the layer in both directions by binning the pixels.

Pixel Aspect Ratio

Adjusts the pixel aspect ratio.

Crop

Crops the layer to the given bounds.

Mirror

Reverses the layer’s left and right.

Flip

Flips the layer upside down.

Rotate Left

Rotates the layer 90° counterclockwise.

Rotate Right

Rotates the layer 90° clockwise.

Rotate

Rotates the layer at an arbitrary angle.

Normalize

Adjusts the pixel values of a layer such that its background matches that of the stack’s pick.

This adjustment can only be applied to images which take part of a stack.

Align

Aligns the layer with the stack’s pick.

This adjustment can only be applied to images which take part of a stack.

Arithmetic

Add a value to every pixel of the layer, subtract a value from every pixel of the layer, multiply a value with every pixel of the layer or divide every pixel with a value. Invalid (hot, missing) pixels are ignored.